Forum Documentation Showcase Pricing Learn more

Add 401 response to swagger api description

Hello,

When retreiving the swagger.json api description from /api/1.1/meta/swagger.json, it seems that the 401 response is not automatically added to each endpoint.

As a result, this reponse is not available when importing the api in dropsource for example and then you have to modify the json manually to add this response.

@emmanuel, would it be possible to add the 401 response to the autogenerated swagger json file?

Thanks

Olivier

I second this…

We need all of the responses added @Bubble

Thanks for posting. I’ve shared your feature request with our engineering team. They will evaluate this request and get back shortly.

1 Like

I can’t connect an action I need to Bubble without the 401 responses included in the exported swaggar from Bubble.

It would be really helpful to me, as a long time user, if this could be added too or at least put onto a developers forefront for the very near future.

Please let me know on this.

@DavidS could you please update this thread?

I know it may appear minuscule, but I’m unable to continue further without all of the responses added to the Bubble swaggar file…

Thank you

We just added this.

4 Likes

There seem to be errors all of the sudden…

We can’t use the swaggar:

image

Disregard…

It may be the tool we are using that is capturing the json as the json swaggar of yesterday prior to this push is also not working.

Will advise further if issue. Thanks