Forum Documentation Showcase Pricing Learn more

Add to Any Share Buttons Facebook link


#1

I am using a Share button to share my page to Facebook. The url I am wanting to share includes a referral parameter

image

The referral code id an 8 character random string eg referral=19aQa5qE

All was working well but now Facebook is adding a further long string /?referral=19aQa5qE&fbclid=IwAR2qN5cFGDHtF_GV0euEhQlB2x4N8fPca-BtxoZMUm0Czsc8q-jddIAkMiQ

So when I now want to get that id when a user signs up by making changes to the referring user

image
image

it no longer works and I get nothing in this ReferringUser field.

How can I limit the id to just the first 8 characters ?

Thanks in advance


#2

That’s odd, because the fbclid is just another url parameter and should not interfere with your referral parameter. If you manually remove everything from and including the ‘&’ in the url, does it work?


#3

You can get the first 8 characters in Bubble using the :truncated to modifier… :truncated to 8 after your Get referral from page URL


#4

Thanks @louisadekoya and @mebeingken . Louis is correct. The parameter is not working. It was in the past so not sure what I have done wrong

Here is the url
image

Here is the debugger

Even though the referral is not empty the workflow is not running as it is showing as empty (Only when is in red)

What am I missing???


#5

All I can think of is to check for spaces in the parameter name, but if as you say it used to work previously, it probably isn’t that. It’s a pity that the debugger doesn’t allow one to inspect he URL itself, in case it is being passed incorrectly for some reason.


#6

I would also check for spaces. If that doesn’t work, try removing the condition and then adding it back in.


#7

Thank you @louisadekoya, @mebeingken and @romanmg. I found I need to have the parameter to the custom state, not the url. I already had a custom state set when the url referral parameter was not empty. I just had to change the workflow to reference the custom state instead of the parameter

I just love the support I get from all of you on this forum. I could not do this without you all :grinning: