Forum Documentation Showcase Pricing Learn more

Bubble not recognizing data in tables during upload - w/screenshots

Every time I try to upload data to my database via CSV Bubble tells me it can’t find one thing or another in a table I am referencing.

For instance - I have a a Types ‘Office Title’, ‘Election’, and ‘Candidate’.

Each ‘Election’ has an ‘Office Title’ and a List of ‘Candidates’. Each ‘Candidate’ has a List of ‘Elections’ and ‘Office Titles’.

I have an Office Title “President of the United States of America”


and an Election with an Office Title President of the United States of America.

but when I got to upload a Candidate with Election President of the United States of America I get the following error

…and this is just one instance. It has chosen to not see States that exist, Candidates that exist (when attempting to do this by Modify), and everything else.

What am I doing wrong?

Bueller? Bueller?

@scottsapire If you are uploading to a list field, the validation step might be misreading something in the file. One approach is to create a test thing directly from the editor, export that as a csv file and then use that format to upload values. If you continue to see the issue, please submit a bug report.

Yes, I’ve done that and experience the same result.

Bubble tech help got back to me and told me that when uploading data in this way, to use the unique ID (so set Unique ID as the primary field for each Thing you are uploading).

You can change the primary field back to whatever you wish after the upload.

Hope that helps other people.

1 Like