Forum Documentation Showcase Pricing Learn more

Bubble Page to PDF - New Plugin from Zeroqode


#81

also, when you try our demo page, do you see the same behavior? (slow/works only once)


#82

No on your demo page it works beautifully. The browser that threw the error was Internet Explorer.

What if you have the demo page change content upon a button click to a different set of pictures? Would the print function still work? I am thinking perhaps the print function doesn’t work repeatedly for heavy pages or elements? The demo page is quite simple and so it can process quickly. Would this be an issue?


#83

did you try only in IE? Do you have the latest version installed? We tried changing the content dynamically with a button click and demo works just fine. Maybe it’s because of heavy pages, we’ll do some more tests, but some real example pages would help


#84

@levon

There are so many variables to adjust to get this right, I have tried page setting to 790 and content onpage to less than 790 but it doesn’t do much for the looks.

This is my editor copy: https://bubble.is/page?type=page&name=single_tilbud&id=kopi-kvalitetsbad&tab=tabs-1

Could you look into it? You have to go to a “tilbud” and “se tilbud” to get the pdf button in the bottom to get to the pdf print page. There the print pdf button is on top in blue.


#85

No I tried in Chrome, Edge, and IE. Failure in all three to do multi prints. I have a feeling it has to do with heavy pages. Perhaps try it on one of your heaviest pages and see if you can replicate there? I know @timgarrett111 is planning to share app and once I clean mine up some I will get it ready for you to view if the problem persists. I am sure as this plugin becomes more popular because of it’s potential, this problem is going to emerge in a much bigger way. Our interests in getting it resolved are aligned:)

Oh and I did instal and reinstall, unsubscribe resubscribe, removed the plugin, added it again. Everything you could think of.


#86

@Bradluffy @levon

Ihave just given Levon Access to my app! Hopefully ZQ can find out why its so slow to download.

Cheers


#87

Weirdly enough I tried with another page which is way smaller and it worked, so are we restrained with the page length ?


#88

Hi @levon,

After quite a lot of fiddling I think I might of found a little bug, for me the Source width & Source height are mixed up… Don’t know if it is only for me or not, is the problem coming from my side or your side ?

Or is it because I used it in portrait and we have to interchange them ? If yes it would be cool to change the names or maybe add it to your documentation :slight_smile:

Thanks for your help !


#89

seems we have tracked this down and fixed it, please upgrade to the latest plugin version, refresh the editor and retest

yes, there was a bug and we fixed it in the latest plugin version


#90

Great news everyone. Thank you all for digging into this. I had a big deadline for yesterday so it is only today I will get an opportunity to implement this completely in my app. I’m so delighted the debugging is already done. :slight_smile:


#91

The only working one time issue is still not resolved? @timgarrett111 did you stop experiencing this issue with the new fix?


#92

we still couldn’t reproduce the one time issue, in any case @timgarrett111 should update the plugin in the app and retest as we don’t have enough access rights for that. @Bradluffy can you give us read-only access so we try to reproduce the one time issue? Plus test user login/password.


#93

Sent you PM with the info to reproduce the issue.


#94

we reproduced it on your page, but can’t debug because we don’t have the access.
One thing - did you deploy the app to live after you upgraded the plugin to the latest version?


#95

Yeah definitely deployed to live several times actually without success.


#96

ok, seems we were able to find the issue and pushed a fix. Please update the plugin version to the latest and give it another try.
Awaiting your feedback


#97

Damn fine work there @levon , will let you know if I spot anything else.

Just to appease my curiosity. What was the issue that was stopping multiple prints? I thought about it for the longest time and I have to know:)


#98

Awesome, glad it’s working :slight_smile:
The issue was related to the way plugin processes image URLs (when they are on the page) :slight_smile:
adding slashes or removing them when necessary…
Please let us know of any additional feedback
Thanks!


#99

@levon I’ve been attempting to get the PDF Converter set up in my app on and off today. I want to have it that when the PDF has been generated that the browser’s dialogue window pops up and asks the user what to do with the file (View or Save). As a fallback, I could live with just having it open the PDF in a new tab. But I can’t seem to get anything to work, not even your text link to view the PDF approach in your editor. I have the same settings as your Convert Page button. I guess I am forgetting something straightforward. Can you point me in the right direction, please. Thanks in advance.


#100

What you have that I can see is that the Upload PDF box is not checked. The second action in the workflow is a URL that doesn’t exist. Click the upload pdf box and let me know if that works.