Forum Documentation Showcase Pricing Learn more

Dates still showing up strangely....but why?!

#1

The user select May but the email says “maj”, which is May in a few languages: http://www.omniglot.com/language/time/months.htm

Why is this happening?

Is it based on the language settings of the computer it is being sent to?

#3

Any ideas? @romanmg have you figure out how to fix this?

#4

Does anyone else have this problem?

If yes, is there any way of fixing it?

In this application, these emails are being sent to customers with appointment times and it’s very, very confusing to them!

#5

Hey Chris!
I would start with checking on how you are formatting the date that is being sent, if you’re formatting them at all.

Also check out how it is looking like when the actual email is leaving your app (you can do that either in the logs or in the debugger).

Also check out the language settings of the application - it does affect the standard way of naming for the months.

#6

Thanks Vlad. I wasn’t aware of this formatting Or the language settings, so I’ll check this out!

Chris

#7

@vladlarin For some interesting reason, this problem has started again. Sometimes the email will correctly say “Apr” and sometimes it will randomly say “Abr”

I’ve double checked that the application is in English. It is

I can’t seem to figure out how to set up “Date Formatting”. Can you help me with this?

Is this in the workflow?
Or the database data type?
Or in the design view when I’m defining the selector?

As reference. Here’s what it looks like when it’s correct

Here is incorrect

My preference is that the entire month is spelled out, not abbreviated, in English always.

Thanks!

Thanks in advance!

#8

Hey @topherwilliams,

When you’re defining the body of your email and inserting dynamic values of the type Date, that’s where the data format is defined.

Not sure how you got to the weird “abr” formatting, but all you need to do is select the CUSTOM value in the dropdown, and set your date to something like that:

mmmm dd yyyy, HH:MM:ss.L

#9

Awesome, this should solve it. Thanks!