Forum Documentation Showcase Pricing Learn more

Freaking out over API error


#1

I’m getting an error:

“an api connector error: this header name if not correct undefined”

There is no header needed or provided associated with this call.

Everything works in postman with the same settings.

@emmanuel in the past, this was a bubble hiccup. Same thing here?


#2

Same problem, any solutions?


#3

It was my API call. Where are you stuck?


#4

Same error, same situation. I don’t know what you were trying to connect.


#5

In my case, the header was not set correctly in my API call to Uber.


#6

Hi @scottb50, i have the same issue: Postman works fine but Bubble returns an error (“API Connector error: this header name is not correct undefined”). How did you solve the problem in your case? Just wondering, since you mentioned that postman worked fine.

thanks!

J


#7

If your header is now correct, a case that can produce this error is when you change the header in the connector multiple times, even if you remove the header it will give you the error. Recreate the call and give it a try.


#8

Thanks for the hint, i’ll try this tomorrow.

Cheers

Jeremias


#9

Many thanks, @jarrad, works like a charm now!


#10

Hi. Just adding a new timestamp that I also ran into the same header error. Seems like a lingering bug (though other posts claim it was once solved). Deleting the API call and recreating it solved the problem.


#11

I think “lingering” has maybe morphed into “permanent resident” :slight_smile:

All I can say is … no matter how good you think you are, don’t test APIs in Bubble. Get it working in Postman THEN copy it across when it is working. Fiddling about with headers seems to annoy Bubble.

Got exactly the same error as above. Deleted and recreated. Works like a charm.


#12

Hate this bug. Love this forum.

Wasted an hour playing with this error


#13

Bubble can be “character building” at times.