Forum Documentation Showcase Pricing Learn more

How to fix BDK Slideable Menu Plugin Icon out of sync with menu?

@gaurav I’m using your sliding menu plugin and am able to get it working except that the sliding motion of the menu icon is out of sync with the sliding speed of the actual menu.

How do I fix this?

Since you can assign the plugin action to any icon, it is entirely up to you. In your example it is performing as expected since the plugin just uses CSS to shift the canvas. Since you also have a Close icon, an easy way to solve is to your hide your hamburger icon when the menu is open and show when the menu is closed. You can do this as part of a workflow or with a state.

1 Like

I mean, if I copy his page to my app then it works flawlessly. However, I’m unable to copy that page to my index page because index is a special page that can’t be deleted or made by renaming his page to “index”

But you’re totally right - that is an option. I would just like to know what I’m doing wrong

I just figured out my problem. My index page’s background style wasn’t set to flat / solid white. That’s all that was missing to achieve the effect.

2 Likes

You don’t need to copy the entire page. Just copy the floating group. On each page you want the menu, make sure the page has a name in the ID Attribute field at the bottom of the property editor. In the workflow editor, create a workflow “on page load”, and call the workflow called “Setup Slidable Menu” and enter the ID attributes of your page, slidable menu, and header if you have one.

2 Likes

This thread truly showcases the awesome community bubble has built :raised_hands:
A bubble user helping another bubble user on using a plugin built by a third bubble user :smiley:

Cheers to the @Bubble Team

3 Likes

I’m experiencing the same thing, and setting the background to flat/solid white solves it. However, I can’t do that, since I have elements in a floating group beneath the page (that will be hidden behind the page background). I’ve tried setting it to flat/white with 0% opacity, but that doesn’t work.

@gaurav anything I can do to get around this?