Forum Documentation Showcase Pricing Learn more

Major Issue During App Optimisation


#1

Yesterday I used the Optimise Application button and deleted some of the bubble suggested unused styles and components. Immediately on clicking the button, Bubble seemed to hang on Saving… . I presumed it will take some time to complete this process. To my horror, today I find none of my app pages are viewable (though listed in the dropdow) or are searchable. I’m completely stunned and don’t know where next to turn!

Promise of optimisation is tempting, but it seem to have caused an issue. I have sent a support message.


#2

Likely due to this: https://status.bubble.is/incidents/fprd270pm05s


#3

Unfortunately the problem remains even after the fix Bubble deployed. I am waiting for further contact from Bubble.


#4

Bubble keep backup of everything. Good news. So let us know the result.
edit: Restore to the last working date-time.


#5

You should restore the app before the optimization, doing this while Bubble was hitting issues got your app in a bad state.


#6

Thanks @emmanuel. I have rolled back to a previous version and that has brought everything back.

I just wonder if the optimisation process caused the instability in the first place, as there was no indication whatsoever of a problem with the platform leading up to my clicking that button! Worth exploring that.

So the lesson for me is deploy the work before trying the optimise, so that you can role back if needed.


#7

No, it was an infrastructure issue with one of our cache servers. It was just unfortunate timing…

But in all cases, rolling back it always an option when something goes wrong.