Forum Documentation Showcase Pricing Learn more

New Plugin from Zeroqode - Video Player


#41

Hi Levon,

I just installed your video player to play a playlist of videos.

My issue: The player plays only the first video of the list.

The videos are currently hosted by YouTube. I store the links to the YouTube videos in my database as a list that I hand over to your video player (see screenshot below).

To explain the dynamic link, I also attached the Custom Data Types I am using to access my list of Video Links (see below).

Custom Data Type User:

Custom Data Type User’s Exercise:

Custom Data Type Exercise:

It would be great if you could help me fix this! Please let me know if I need to clarify anything.

Thank you!
Nicola


#42

Hello, Nicola,
Did you try supplying the same list of videos in a simpler way? (without nested objects of multiple layers)
you can try to experiment with setting a custom state or a database field with that list and see if it works, if it doesn’t then I’d suggest to check if each video from that list works separately. There might be unsupported formats or something like that that you used


#43

Hi Levon,

the player also does not work if I type in the video urls separated by a comma. (See screenshot)

Regardless what I do (I tried a lot of different things) it only plays the first video.

Another thing that doesn’t work: If I upload a local video from my dropbox, it runs in the browser when I click ‘see’, but it does not run in the video player (see screenshot below)

Could you please check this in more detail? Maybe there is something wrong with the player?

Thank you,
Nicola


#44

Hi Nicola,
we’ll check this out and get back to you asap


#45

Thank you Levon! :slightly_smiling_face:


#46

Hi Nicola,
we have fixed the bug with playing lists, please upgrade to the plugin’s latest version, refresh the browser and give it another try.
Thanks


#47

HI Levon,

Bubble tells me that I installed the latest version of the Video Player (See screenshot) and I also refreshed the browser, but the player still only plays the first video. Could you please check what’s wrong?


#48

Hi Nicola,
the latest version is 2.13.0
please upgrade


#49

Now I’ve got the upgrade. The playlist works now as long as I use Videos hosted in YouTube. Thanks for that!
What still does not work is playing videos that I upload from my dropbox. They will be uploaded and play in the browser when I click “see” (see screen shot). But they will not be played in the player.


#50

dropbox videos use different technology to stream… at the moment we don’t support that.
is it crtical?


#51

Thanks for the answer! No it is not critical right now. I wanted to access dropbox merely for testing.
I would like to stream the videos from a database, not from YouTube. Ideally the playlist should look like one long video. Do you have a suggestion how I can achieve this? What would be the best solution using your player?


#52

you can source videos from DB that should work fine, there will be some pausing though between switching from one video to another (but that happens on youtube too :slight_smile: )


#53

Hey Levon… ever since the last update the player the state for the time is not working. So i can not get the player position


#54

Hey Ryan, this has been fixed, please upgrade, thanks!


#55

Hi Levon,

I just uploaded my videos to the DB, but the player does not play them. It’s just black.
Could you please check what’s going on?

Thank you!


#56

can you share a screenshot to see how you uploaded your videos to the DB and how you configured the data source for the playlist in the plugin?
Please also share links to the videos that you are trying to playback?


#57

Sure.

This is my DB table. The videos are stored in the column “Video file”:

This is how I call the video player (I have tried different options, including uploading the videos as static videos directly to the player. Nothing works):

Here are some of my video files:

//s3.amazonaws.com/appforest_uf/f1547603543242x937753288104501600/1-02-Hüfte%20mobilisieren.mp4

//s3.amazonaws.com/appforest_uf/f1547603576914x541222367492463000/1-03-Hüfte%20nach%20oben%20ziehen.mp4

//s3.amazonaws.com/appforest_uf/f1547603624498x316180185259360640/1-04-Oberschenkel%20Aussenseite%20Dehnen.mp4


#58

did you try adding https: before the link?
do these file work individually?


#59

Yes, I tried both. It still does not work.


#60

Hi Nicola,
we have found one bug and fixed it, chances are high that it will solve your issue too, can you please upgrade the plugin version to the latest, refresh the browser and retry?
Thanks!