Forum Documentation Showcase Pricing Learn more

New Plugin- Fuzzy search and autocorrect, custom search boxes


#41

Thanks mate, the reset works great. Anyone have suggestions on how to trigger a new search (without typing into the input) if the input value is unchanged?

Potential use case: the input value is “houses in new york city”, but the user clicks a button to change a custom state (e.g. median house price >1 million dollars), so the search is then filtered to only include “houses in new york city” that are > 1 million dollars.


#42

Hi,

I’m having a great time with this plugin and it works like a charm when searching for any type of item I have created in my database, but I’m having troubles when I want to search through a simple list of texts with it. It doesn’t return any result of type text.

I guess I’m missing something… Could anyone explain what’s happening in that scenario? Is it because it can only return a thing? :slight_smile:


#43

Hello @dambusmedia
I’ve tried to use this pluggin in a reusable element (header) and it seems it’s working only in one page (the one that’s first loading on preview mode) and not on the others
Can’t figure this out for the moment. Is this a limitation of the pluggin?


#44

@Lucien, yeah, it expects Things. In your demo you’d need to set the data type to “Some_Data”, and then choose “Some_text” as a field to search.

@tdevasselot Did a quick test and it seems to work in a reusable element for me. If you can post a demo of the issue you’re seeing I’ll take a look


#45

Thanks, got it.


#46

@dambusmedia
It is very strange… I have some pages where the pluggin seems to work perfectly and others where it doesn’t.
Here’s a link to a demo
You have to check on different pages to be sure wether it’s working as expected or not.
On my side, on this demo app, it’s only working on index, book and bob_search pages, but not exactly the same way for the same search(!)
You can login with the account : debug@matris.fr and pwd : debug


#47

Hi Dambusmedia,
I am having a little issue with your amazing search plug- My search box doesnt seem to work in parallel with my repeating group search. I followed your step by step guide but still not working. Any chance to assist on this? @dambusmedia


#49

Is it possible that the plugin is not searching through data obtained from an API get request? I don’t have a an app database and I need to search from an external API datasource. Debugging tells me this: image


#50

That really works. Perfect and Thanks for sharing


#51

Hi
@dambusmedia
I have fix my bug.
The issue I was facing coming from a kind of unrefreshed reusable element. While I haven’t gone to visit one page containing the reusable element in UI builder, the last version of reusable element was loading. Since I have visited each page in UI builder, it has take into account the modifications of the reusable element in each page and everything is working fine!


#52

Hi @dambusmedia,

Would it be possible to reset “Input box’s value” when using the workflow reset action?

Right now I believe it is only resetting the matches and matches scores but it leaves the Input box populated with the last value. This is tampering with conditionals to set Data Source in the associated RG.

I don’t know if there are any other implications about this of course :slight_smile:

Thank you very much,


#53

Hi @dambusmedia,

Just following up. Is this possible or does it have some other implications I’m not aware of?


#54

Hi,
Thanks for the great plugin that works like charm.
I am though facing some trouble with the reset input function which doesn’t look to be resetting the input box completely: the input search text is actually erased and the search results disappear but the number of characters of the input search box looks to be kept in memory until a new search text is actually typed.
Not a big issue but I have some conditionnal formatting based on the Search&autocorrect input box’s value:number of characters that I would like to see work properly.

Any idea?


#55

@stev.lecorre you could try using it alongside the Instant Text plugin. Not only will it make your searches start faster, it will work exactly as you wish, I know because I’m doing exactly that so I asked the Instant Text author to provide a reset action for it. Any conditionals that look to the Instant Text’s element react faster than they do to changes in the bubble Search.


#56

I received a pull request with a fix for this issue on github. Haven’t had a chance to test it yet but I’m pretty sure it fixes the issue you’re seeing. I’ve pushed an update.

I think it was @JonL who provided the fix, so thanks Jon! Haven’t had any time to spend on my plugins for a while now…


#57

Anytime :slight_smile: Good thing you had the GitHub repository visible :slight_smile:


#58

@dambusmedia @JonL
All solved thanks!


#59

@dambusmedia can you tell me what I’m doing wrong, please. I have started to experience my app hanging. Firefox shows the “A web page is slowing down your browser” message and Safari just shows the spinning beachball and Chrome just hangs for a while.

I have a data table with about 4,500 records. There are three text fields that are concatenations of data. Sample below.

I put a simple RG (Fixed at 3 cells) on a page with Do a Search for and it is fine.

As soon as I drop an S&A element onto the page (I left parameters not shown below as default values) and set it to the same search as above, pointed it to the input box, and to searching the three fields everything hangs.

That is before I try typing anything into the input box. If I wait long enough I might be able to type a character or two into the input before it hangs again. I’ve set up a simple page in my app if you need to dive in PM me.


#60

@dambusmedia - I’m still hoping to hear from you if you have any idea what is causing my machine to go unresponsive (regardless of browser) as soon as I used an S&A element on my page. I’ve done as much debugging as I can and I have discovered that it happens when the S&A is pointed to my Job Cards table, regardless of the field to search. So it is not what is being searched for, or what fields it is being searched against, it happens regardless as soon as I point it to the Job Card table which has 4,500 records.

I have a customer demo tomorrow so if anyone has any ideas please let me know.


#61

@patricia, I suspect that’s simply too much data for the algorithm to handle. You’ll need a backend solution and a way to generate indexes on bubble’s database side to handle a dataset like that, which only Bubble can do at the moment as far as I’m aware.