Forum Documentation Showcase Pricing Learn more

🗃 New plugin - Multi-Uploader [BUBBLE AWS + UPLOADCARE + FILESTACK + AZURE] BIG Update: 11/06/2018

#184

Hi, so I noticed that it shows a preview of an image that you upload. Can it do that for a PDF or Word doc where you can see the documents content

#185

i can answer that… no you cant… BUT you can use cloud convert to make a thumbnail and then show that after the upload. I would use zapier, send the image to cloud convert… make thumb… then use the cloud convert trigger zap to send the process image back to bubble via api webhook.

#186

Thanks a lot @ryan8 :slight_smile:

#187

Does anyone know how I can get the nice uploading design

#188

It looks like you haven’t added the Initalize workflow:
image

Best to action on page load.

As for customising the element you can use some custom CSS

e.g.

1 Like
#189

@zeroqode

Is there anyway to define more than one instance of a accepted file type MIME. As I’d like to only allow uploads that are document types or images e.g. PDF, Doc, JPG - when I type more than one, it doesn’t register.

I thought I’d might be able to feed a list of MIME types as a list of text, but still doesn’t work.
image
image

But with doing so, the Uploader element comes up with ‘undefined’.

Would be greatly appreciated if more than one can be defined e.g. we could allow the use of:
image/jpeg, application/pdf
defined in the ‘Accepted FileTypes’

Cheers

1 Like
#190

Hello @luke2.

Thanks for feedback. We looked into the issue and the feature was fixed.
Please upgrade to the latest version of plugin.

Here’s the example of the settings:

And the result:

Check the demo for configuration and testing: https://redubleplugins.bubbleapps.io/multi-uploader

Regards,
Zeroqode Team.

2 Likes
#191

I have been experimenting with the File Type validation but I cannot figure out how to make it work to only accept CSV files. I have tried the following MIME types but it does not filter correctly:

text/csv
application/csv
text/x-csv
application/x-csv
text/x-comma-separated-values
text/comma-separated-values

Any ideas on what format I need to use to only allow the user to select a CSV file?

#192

Quick idea, try just

.csv
1 Like
#193

That worked! Never thought to just try the file extension. Thanks!

#194

Sorry for the late reply, plugin works perfect on multiple projects now :slight_smile:

This plugin was the problem:

It adds weird code…

#195

Great to hear @eddy
enjoy :slight_smile:

1 Like
#196

I seem to be getting allot of errors from this plugin suddenly.

@levon

#197

how do you know it’s from this plugin?

#198

yea uploader b is this plugin… i am only using this uploader on this project so its not one of the other ones. I am using two at the same time… i dont know if there is an issue with using 2. I mean they do work… but there are a bunch of errors too.

#199

if you remove 1 of the plugin instances, are the errors gone?

#200

also did you try uninstall and reinstall the plugin

#201

Maybe it’s already asked but any plans on adding: https://pqina.nl/doka/ to the plugin? To edit the uploaded content. The developer is open to talk about it :slight_smile:

#202

Still getting this: There are 3 of them and only 1 of them throws the error… the other 2 are fine.

The plugin Multi-Uploader / element Uploader threw the following error: RangeError: Maximum call stack size exceeded
at t.request (https://dhtiece9044ep.cloudfront.net/package/run_debug_js/a018c82a60806b109a26578eed98eef582a0e932692a1a3a8499f9491db92a6d/xfalse/x5:15:104069)
at t.post (https://dhtiece9044ep.cloudfront.net/package/run_debug_js/a018c82a60806b109a26578eed98eef582a0e932692a1a3a8499f9491db92a6d/xfalse/x5:15:103568) (please report this to the plugin author)

#203

@zeroqode when I set the max to 1 file. On mobile the user is aloud to select multiple images and then when select add it does nothing. Users think the app (upload) doesn’t work + that they can upload multiple files instead of just one. Is there a way for me to fix this or…?

Hope you can help :wink:

*ps the max files does work on desktop.