Forum Documentation Showcase Pricing Learn more

Possible To Limit Decimal Points to 2?


#1

Is there a way that i can limit the numbers after the decimal points to 2 instead of having a bunch of trailing numbers?


#2

Yes, use the formatted option after a text in the dropdown.


#3

Is there any way to format the decimal limits to two on an input field in a “decimal” or “integer” format? Also when the input format is “percentage”?

Also when trying to format the numbers thousands it´s just showing “space” and “comma” but no “period”. Can you make it available?

Thanks.


#4

“Integer” shouldn’t have any decimal places at all, that kinda defeats the purpose of specifying something as an integer.


#5

You´re right @potentialthings,

What about the others?

Is there any way to format the decimal limits to two on an input field in a “decimal” format? when the input format is “percentage”?

Also when trying to format the numbers thousands it´s just showing “space” and “comma” but no “period”. Can you make it available?

Thanks.


#6

I need a “.” for thousand separator too.


#7

@emmanuel, could you give us any update about when is it going to be available the “.” for thousands separator?

Thanks.


#8

It’s not close on the roadmap unfortunately.


#9

At least this year?


#10

Depending on users’ request. I haven’t seen much of a ‘.’ for thousand separation though.


#11

Well we are two by now but really interested, hehe.

Hope there are more interested.

Thanks.


#12

Hi, I am trying to enter an amount figure in a Decimal field, using an Input control.

I could use the Currency type but I don’t want the currency symbol to appear. It looks like the “blank” choice cannot be selected.

In my country the amount 12.34 is written 12,34 with a comma as the decimal separator.

Similarly, the amount would be formatted using a period as the thousands separator, like in 1.234,56 for onethousand-twohundreds-thirty-four point fifty-six

Where should I go in order to allow this behaviour. At this point the app is totally useless because the devices will provide a numeric keypad with ‘,’ instead of ‘.’ as the decimal separator.

Kind Regards
Mario


#13

Use “:formatted as” after the number.


#14

Hi Scott,
I’m sorry but I can’t find “:formatted as” in the Input properties. Could you please help?
Appreciate this is a newbie situation :slight_smile:
Thanks!
Mario


#15

Did you figure out how to use “.” for thousands?
My application will be useless if I cannot use “.” instead of “,”.


#16

Nope. Best guess would be to allow text input and use formatted text as the user leaves the field. Never tried though. I still believe it’s a big limitation


#17

Yes, it is.

If I can’t work around this limitation, my project is dead.


#18

Hey folks…

Is there any way to make the number of decimal points always two on an autobound number? With autobinding, the “:formatted as” option isn’t available!

Antony.