Forum Documentation Showcase Pricing Learn more

Quite Impossible - Be careful when running API Flows in parallel


#1

@emmanuel

I will try to keep this short:

Say I run API flow on a list of records with a common parent,
During this flow I try to change this common parent,
The parent does not change accurately as all flows finish running.

I do not know how Bubble is set up but it kinda seems to be the DB problem: API flows run after each other with a very short gap in between, but this gap is not enough to update a record in common, hence the BUG tag.

The application of the above is to safe time when running flows. Equivalent loop for what I am trying to achieve takes significantly longer (despite flow actually being quite simple).

I spent 3 days trying to work things out but no result. Can this behaviour be fixed?


#2

I’ve encountered the same. What I’ve resorted to is employing a “housekeeping” workflow that runs after all of the workflows on a list finish. (Ie. a second API workflow updating the common parent 30 seconds later or as part of an on-page workflow the next time the user requests the data point with the common parent).

For example, when I have an API workflow on a list, and the first item is a create a thing or make changes to a thing, followed by a step two that references a common parent, it is consistently unreliable. (I’ve tried different permutations between add a simple item, set list, etc., all with mixed results).


#3

Also encountered this issue and have not been able to fix it and have resorted to restructuring work-flows and databases, which is not ideal.


#4

I’m receiving an exception (only Development environment) in one API Call! This part are not being able to run in Debug mod as well. I tested just the API call and is working fine. There wasn’t any updat at this code. At live enviroment is working fine.


#5

@StevenM @ualdir

I kinda had it working a couple of times (no consistency!) where I added add extra steps to extend length of script but this is just silly.

I also tried to implement a “housekeeping” flow on the side but it works only if I know how many levels of children are going to be “touched”, which is not helping if I have nested records (i.e. children of children and so on).

I personally do not see why this can’t be fixed. Any suggestion how we could get Bubble to help? Or would it be quicker to give up?


#6

This topic was automatically closed after 14 days. New replies are no longer allowed.