Forum Documentation Showcase Pricing Learn more

Shared parameters in GET call


#1

Alright all you plugin geniuses…I am setting up a plugin that will have a few dozen api GET calls. I need to provide a common apiKey parameter in the url, and I’d like a common base url. I’ve been able to make those work easily by placing them on each individual call so that these values can be set from the user plugin page.

My question is, how can this be done once for all calls, rather than having to enter for each call? There is a shared parameters setting, but I’m not seeing how to reference that in the GET url.

Can this be done?

Related, shouldn’t the Private Key in URL work for this? I can’t get that working either.

Luckily it all works on the individual calls, but hoping to consolidate.


#2

I noticed this issue the other day when implementing oAuth manually.

You can’t access the shared header or parameters, or dynamically set them in workflow, because there is not a “Public” value. Maybe we can get the @Bubble team to add the value?

The individual calls have “Public”, along with “Hidden” and “Secret”.


#3

Thanks for checking in here Keith.

That actually won’t help me personally, as I don’t want these public, I want them secret so they become parameters on the plugin page rather than settable in actions, etc. Also so the api key is not shared in the client.

Either of these are what I’m trying to do:

Self-handled using a shared parameter:

Or using the Private key in URL:


#4

I think shared items automatically get added, no need to try to reference them in the individual calls.


#5

I’m having this exact same issue, and the shared parameters aren’t being added automatically. I paste them into the individual call and it works, I paste them into the “shared parameters” section and they no longer work.
Have you guys here, or anyone else, figured out how these shared parameters are inserted in the URL?


#6

Not me…I went the same route as you, just copied them into individual calls…it was just easier than finding the root problem.


#7

Well… a bit more manual work then. No big issue anyway. Thank you for answering!