Forum Documentation Showcase Pricing Learn more

SOLVED The page didn't load the Google Maps correctly


#1

Hello guys

I’m having a small issue,related to Google Maps
Once i setup my domain, i got this issue:

On Bubble domain it works fine
I’m using this code: http://elride.dk/version-test/aaa
Link to page: http://elride.dk/add_ride


#2

if you look in the console …

There are several things that are not right.


#3

i have seen that but i can’t really figure out why is not working.
is this code correct?
src=“https://maps.googleapis.com/maps/api/js?AIzaSyCMqXcYXj7oekaPfh747jas8WknVmpKCy0 Key&callback=initMap”>


#4

The problem is related to the HTML block where for some reason the API key is included more than once. Enable iframe and try again


#5

Thats was the issue. Thank you @AliFarahat
Thank you @NigelG for showing me the issues in the console :slight_smile:


#6

Hi @AliFarahat,

sorry to ask but i have an issue with google maps too. I am in bubble preview and since yesterday I got this issue :

So I went into the javascript console and it shows me this :

so, i followed the google instructions, but it doesn’t work, i’m missing something but i don’t know what and how to fixed this… I’m quite frustrated, i was supposed to launch my app today…
I created multiple keys but it doesn’t want to work…

could you please help me on this one ? i am completely lost…

thank you very much !


#7

Can you DM me a link to the editor? I will have a look


#8

I have same issue. how did you guys solved it?


#9

Hi Guys

I am having this issue but in my case the error is RefererNotAllowedMapError. I added the referral sites in the google console but that was no help.

I did notice that in this error I don’t get the url that is not authorize to use this api key.

Any thoughts on how to fix this?