Forum Documentation Showcase Pricing Learn more

Sorry, you do not have permission to modify this


#1

I have a simple screen that has inputs automatically bound to the page’s thing, when I try to make any changes to the values of the inputs, I receive a popup message: “Sorry, you do not have permission to modify this.”

What am I doing wrong?


#2

Welcome to Bubble and the Bubble forums!

As the autobinding option in the config interface for your inputs clearly warns you, you must set up a privacy role that allows autobinding. Do what it says.

(And note that there is also contextual help in the Bubble interface — hover over the autobind checkbox and a link will appear to the reference. Reading up on autobinding is interesting.)

Hope that helps!


#3

Thanks for the response Keith. I see that I have to create at least one role in the privacy setting in order to allow auto-binding. It now works and the page is able to save / update data.