Forum Documentation Showcase Pricing Learn more

Vanilla Rich Text Editor BETA 5 UPDATE (THEMES)


#81

Hey Scott,

Add this to the page header area

<style>
.modal {
z-index: 9999;
}
</style>

That should resolve the issue


#82

I will propably add an option to have this automatically introduced based on the editor options down the line.


#83

Identify the Dib that hosts the element and add a similar change to the page header as I did above

The thing is bubble does it’s best to align the z-index but depending on your page setup you may need manual intervention


#84

Thanks for creating this, @AliFarahat - My use case is fairly simple: We use this text editor to edit content. We have a table that is “Activity” and then an item that is “Activity Content”. Normally, when we hit “save”, it uses the original rich text plugin as the source to update the “Activity Content” for that specific activity.

I’ve tried to swap the Vanilla RTE in place of the original rich text editor and for some reason it’s not updating the item in the database. All other fields are updating correctly (i.e., the multiline input with normal text) when we hit save so it’s definitely an issue with Vanilla RTE.

I assume I am doing something wrong here. Thanks for your help.

Update: At this point, I’ve repeated the same process several times and have had very different results. Mostly, the input does not update the database.

I’ve tried changing multiple fields and experimenting with every combination I could possible come up with. Is this a verified bug?

Also - Placeholder text should have the option to be dynamic text.


#85

Hey There please DM me I will be happy to help


#86

I do have similar results as @maryfox20 , I use RTE as blog editor to save HTML, I have an RG of blogs and when I try to click edit blog btn to edit a specific blog, I have a tab opens with the Vanilla editor (group not popup) but the blog content sometime don’t show up on the editor and sometime they do, when they do, it doesn’t always save the content of the editor to database even though the editor contains something.

When clicking Edit btn I use "Insert to update the editor with the content:
1

After saving I use reset to clean up the editor for the next edit.
2

Some time when I save the content in the editor all I get is HTML tags, even though it contains content and texts.
3


#87

Hey guys thanks for the feedback. I need to debug this so can we have a Skype call so I can better understand how to reproduce this. I am available all day today so please DM me


#89

Hey @AliFarahat
How should I save the editor’s content ?

  • With a right-click, there is no “Start/Edit workflow”
  • In the workflow page, Vanilla RTE is not in the list for element “When an input’s value is changed”
  • And I’ve not seen auto-biding function neither in the vanilla rte’s menu
    Thanks for your help

#90

Treat it exactly like a regular bubble text box


#91

Do I have to click on a “Save” button each time I want to save my text ?
Is there a way to access the trigger “when Vanilla RTE’s values changes” ?


#92

That is not available in the plug-in builder. Will work binding in the upcoming weeks


#93

Bug Report:
If the border style is set to None then some odd expansion happens on the element.
When I set it to solid or any other it works.

See video here: https://www.screencast.com/t/g2Psjtf8eq


#94

Maybe I am missing something, but how do I get the @mentions to be clickable in output?

I a simple comment system, mentions are usernames, but how do I convert the @joesmith to http://helloworld.com/joesmith

Thanks :slight_smile:


#95

Hello @kelly.kampen

Thanks for letting me know. I will look into it and try to reproduce. I will keep you updated


#96

@AliFarahat Any idea on how I can make @mentions linkable?


#97

You can’t. The needed customization can’t not be generalized easy for everyone. If you like you own copy of Vanilla RTE with this DM me


#98

@AliFarahat Has this issue been fixed or am I doing something wrong? I just subscribed to the plugin, but anything typed in a Vanilla RTE does not get saved to the database. I have a workflow that is setup to save the Vanilla RTE’s text output to a text field in the database, but nothing gets saved.


#99

I also get the following error:

The plugin Vanilla Rich Text Editor Pro threw the following error: TypeError: Cannot read property 'Autocomplete' of undefined
at mapPlugin.initMap (https://dd7tel2830j4w.cloudfront.net/f1508987916337x368028988363221300/summernote-map-plugin.js:105:56)
at HTMLDivElement.summernote.init (https://dd7tel2830j4w.cloudfront.net/f1508987916337x368028988363221300/summernote-map-plugin.js:231:26)
at HTMLDivElement.dispatch (https://dhtiece9044ep.cloudfront.net/package/run_debug_js/0c70bba8622568e5c182560fe4e3e54eb33a8e07254dbc590ef114c37d40f3d3/xfalse/x1:9:10315)

#100

The error above is related to the map auto complete plug-in in the Vanilla RTE. If you activated this option with out adding a map key you will get this error. There are 2 options here.

Disable the map plug-in or add an Google map API key


#101

I am not aware of this. No one else have reported this in the new update. Can you DM me with access to the editor to debug