Forum Documentation Showcase Pricing Learn more

Webhook response in header


#1

How do I return data to API and include the header for x-hook-secret?

I’m trying to connect to Asana. I can detect the data from the webhook and x-hook-secret shows but not able to conclude a handshake because I think I’m doing something wrong somewhere in the response.

How do I direct it to a custom header. I use Integromat and this is done easily.

Or can this not be done in the free plan?


Webflow Integration
#2

This is my detected data

Now how do I respond with the header. Here is where I think Im doing something wrong :thinking:


#3

To confirm, you can set up an API workflow on a hobby plan, but it wont run unless you’re on a paid plan. Otherwise looks like you’re on the right track.


Webhook URL issue
#4

Thanks Dan. Thats a shame I wish I asked 3 days ago. Have been struggling with this :rofl:

I wish Bubble had a feature to allow you to try it for a set amount of days, kind of like the boost feauture to get the feeling of a paid plan. Just to make sure that the idea Im trying to execute is actually feasible. Or could be available in developer mode only.


#5

Agreed, putting myself in the shoes of someone who hasn’t been on a paid plan before, it would be nice to do API-based experimentation similar to the boost feature.

My feeling is that Bubble’s pricing for the personal plan is fairly reasonable for experimentation. You can always start with a month to month professional plan.

Generally speaking, most all things are feasible within Bubble - it’s just a matter of figuring out how to do it. :smiley:


#6

Are you sure that its considered a scheduled workflow. The weird thing is if I post to the webhook api endpoint and the next step is create a thing, it creates a thing.

So I think the data does go through but somethings wrong with my return data to api settings. I need to respond with the data in the header not the body. How to do that?


#7

@gf_wolfer I see you had similar issues. How did you manage to return to api as header.


#8

Once I detected the Webhook data I was able to access all the info I needed. I did have trouble receiving a webhook in the first place for a while which I never did figure out, but things seemed to have worked out when I revisited things later. Sorry not much help for this specific case


#9

@dan1 upgraded my bubble plan and still can’t do it. :persevere:

Anyone? @NigelG Always helpful :slightly_smiling_face:


#10

@dan1 Webhooks to Bubble endpoints work for every plan. The paid plans are needed when you have a high volume of webhooks and need the processing capacity.

@amdmakki Is problem you are having about API workflow not allowing you to set header values on the response to Asana?

You have two options as I see it:

  • Request Bubble to add the functionality to set headers on the response. I suggest using a bug report to request it, link is on the Bubble home page > Community.

  • Use an intermediary server to receive the webhook, post it to the Bubble app endpoint, wait for the response, then add the header to Bubble’s response and respond to Asana.
    A disadvantage of this is having to use the intermediary for all the webhooks, not just the initial handshaking.

It looks like you have already started trying this with webtask, if you send me a PM I can give some direction.


#11

@mishav - thanks for correcting me. I had mentally lumped them in the same bucket a long time ago and hadn’t tried to test otherwise.


#12

Thank you so much @mishav for your concern. Sending you a PM


#13

@dan1 a common aspect of webhooks is expecting a quick response, so you are right another way … ideally the endpoint would save some info from the webhook, schedule another endpoint to do the processing, and respond to the webhook.