Forum Documentation Showcase Pricing Learn more

Why does scheduling an API workflow on a list take so long?

I have an API workflow set up to create new things connected to a project object. There are roughly 50-60 projects in the list. When I schedule an API workflow to run on this list of projects to create a new thing for each project, the blue loading bar at the top of the page appears and takes 30-60 seconds to finish. It seems as if this loading bar is shown as the API workflow is running, and if I look at the database they are all created by the time the blue loading bar has finished. My understanding was that the API workflows should run server side so the user is not waiting on the workflow to finish and slow down the UI. Am I missing something?

Something is not correct (you must have something running client side) scheduled API workflow is not client side so in effect you should not be seeing the blue progress bar. Sorry for the obvious question… What is the debugger saying

Alternatively screenshot of your workflow?

Here are some screenshots of the workflows.

If I do step by step in the debugger, it hangs on the “Schedule an API Workflow on a list” step until the API workflow has finished. I then get a message saying "Your application could have been 141 seconds faster since page load with more capacity. " I’m on a personal plan right now, but I tried boost and it didn’t make much difference.

Thats interesting thanks for the reveal…has this just started happening or is this net new?

The reason i mention it is that up until a few days ago, my schduled API workflows without issue. but over the last week… they hang (in the debugger like yours) until the whol;e API workflow in the backend has run.

I’ve tested sperate senarios to try and replicate…with much success. I think its worth submitting a bug report.

Also i noticed other threads on deleting things taking ages… maybe Bubble is changing stuff and this is the outcome

I haven’t noticed it on other API workflows, but I need to check the others to see if it does the same thing.

I have submitted a bug report and will update the thread with what I find out.

2 Likes

Having the same issue. My app has been slow for a while and I have just isolated this as the issue, app runs fast without a particular api running.

You might try having a “middle-man” endpoint to see if you achieve better results.

Create an endpoint which has the sole task of receiving a list and the let IT be the workflow that schedules the individual add_checklist_item calls. From the client side workflow, schedule an api (not schedule on a list) and pass the list as a single parameter to your middle man.

2 Likes

I’m confused. Are you saying that when running an api workflow on a list it should be fast enough that no blue bar would appear?

Yes, have had the same issue. ^^^^ is the answer.

1 Like

Would you mind providing a screenshot of how you pass the list as a single parameter to the middleman?

1 Like