Forum Documentation Showcase Pricing Learn more

ZQ Rich Text Editor - New Plugin From Zeroqode


#21

I still don’t understand why the RTE input works differently than a regular input, but regardless I attempted to follow your instructions. I can’t find a workflow that allows me to set initial content for the RTE. I see the item “Set initial content for RTE - Main version” as an action, but when I click on that to add it to my workflow, it will not allow me to select my RTE element. Where in my workflow would you suggest I add this?


Set%20Initial%20Content%202


#22

When using the SET INITIAL content a RTE… it throws the following error: The plugin ZQ Rich Text Editor threw the following error: TypeError: Cannot read property ‘clipboard’ of undefined
at eval (eval at g.create_code (https://dhtiece9044ep.cloudfront.net/package/run_debug_js/5494513987b342a63c3967ccf1fd964518e4525f69267e5edccb59f83eab9b67/xfalse/x3:101:12439), :3:451)
at https://dhtiece9044ep.cloudfront.net/package/run_debug_js/5494513987b342a63c3967ccf1fd964518e4525f69267e5edccb59f83eab9b67/xfalse/x3:102:3319
at N (https://dhtiece9044ep.cloudfront.net/package/run_debug_js/5494513987b342a63c3967ccf1fd964518e4525f69267e5edccb59f83eab9b67/xfalse/x3:101:26119)


#23

Hey Ryan,
we’ll check this out and update here


#24

Hello,
Thank you for reaching us out. We were not able tor reproduce the issue on our end.
Would you agree to add me as collaborator to your app, so we can check it for you?
karel@bubblewits.com


#25

Hi @levon

I like this plugin, Does it support RTL?


#26

It should, give it a try :slight_smile:


#27

Karel,

I asked a question earlier in the thread and the response to me was to use the SET INITIAL content a RTE workflow. I received the same error that @ryan8 describes when I tried to do that. I ultimately unsubscribed from your plugin. Still following this thread and interesting to see that someone else reported one of the problems I was having with the plugin.


#28

Another issue: when adding images to a text field through the editor and trying to render its HTML output in bubbles html object, the content is fine. However, when i try to grab it with your other plugin PDF generator, It causes your other plugin (PDF generator) to fail at making and downloading the PDF.

The app never gets a response back and the file is never delivered. It only happens if i add images using the RTE image upload function. Any images added manually work fine.

Heads up :slight_smile:


#29

I should add it only throws the error on the first click… but every click after is fine until a page refresh


#30

@accounting , @ryan8
sorry you are having these issues, we’ll try to investigate and see how we can fix it


#31

@ryan8, @accounting we have deployed a fix to this issue, please update the plugin version, refresh the editor and give it another try

this is a Bubble issue and we’ll inform their support


#32

So the error went away but now it does not send the data to the plugin. At least if it is in a popup. I upgraded, refreshed, and redid the action. But nothing shows up int the editor now. This could be an issue when sending it to a popup though? It use to work in a popup before this update. Is there anything else i would need to do to make it work in the popup?


#33

We’ll check this out


#34

@ryan8 we have pushed a fix to this issue, please check it out


#35

PERFECT!!! Works like a charm!!!


#36

Great, glad it works :slight_smile:


#37

We have just pushed an update to the plugin and it now supports Google Fonts