Forum Documentation Showcase Pricing Learn more

ZQ Rich Text Editor - New Plugin From Zeroqode


#61

Data field can be clicked but mention source field can not.


#62

We have checked a few times and eveything seems to work fine. please see this demo page where you can check if it works correctly or not. https://bubble.is/page?type=page&name=rte&id=zeroqode-demo-06&tab=tabs-1
if it doesn’t work as on the demo page i’d suggest uninstalling and reinstalling the plugin (nothing should break when you do this), also you could try moving the element on the page 1 px right and then left to reinitiate it. If none of this helps I guess you’d need to file a bug report with Bubble https://bubble.is/bug_report
thanks


#63

Hi Levon,

This past summer you attempted to help me use your editor in my app. At that time I couldn’t get it to work right for me but I’ve continued to follow this thread. Thanks to your responses in November to @gregjohnkeegan and the links to your demo editor, I think I finally understand the Set Initial Content Action. However, I still can’t use that Workflow because I’m unable to select my RTE element. It is not available in the element dropdown list. I think I’ve narrowed that down to the fact that my RTE element is within a repeating group. Do you know why that would cause it to be unselectable? I’d be happy to share more screenshots or give you access to my app. Thank you! Set%20Initial%20Content%202


#64

Hello, @accounting.

Sorry for a late response, but according the screen, I see you’re trying call the element RTE via workflow by having an external button call outside of this Repeating Group but that’s not possible. That’s how bubble works, you could try with other input forms and you’ll not be able to set that element in the workflow from outside the Repeating Group.
Maybe you could share what is it you want to accomplish, so we can guide you through.

Regards,
Zeroqode Team.


#65

I was trying to find your demo page with the Thing called Fruits to use as an example but I can’t seem to find it this morning. Perhaps you could share that link with me? I’ll try to explain anyhow:

As I recall, in your example, you had a dropdown list that showed various Fruits and then you had an RTE box that allowed you to edit the description of the fruit that you selected. Imagine that you have multiple types of food (i.e. Fruits, Vegetables, Dairy). So you have a dropdown that lets you select the type of food and a repeating group that displays details about the individual food items related to the selected type. So now you’re choosing Fruit from the dropdown and seeing an RG list of Apples, Oranges and Bananas. And you want your RTE to let you edit this list. This works fine for the initial selection of Fruit. (See Image 1) The RG poplulates and you can edit the food types. When you change your dropdown from Fruits to Vegetables, the repeating group with a regular text/input updates accordingly, but the RG with the RTE doesn’t change the food types displayed. (See Image 2)

So what I understood you to say earlier was to use the Set RTE Initial Content Action with the workflow of When Dropdown Value Is Changed. That works fine when I’m setting the content of a single RTE based on the dropdown’s value. But it does not work when I’m trying to set the RTE inside of the RG.

Image 1

Image 2


#66

Hello, @accounting.
I see, we tried to reproduce this so we’ll look into it.

Thanks for understanding.


Update:
Hello, we pushed an update for the plugin, please upgrade, refresh the browser and give it another try

As well a test version of the plugin using your scenario - https://zeroqode-demo-06.bubbleapps.io/rte-test

Regards,
Zeroqode Team.


#69

I think the content is changing appropriately now. I’ll let you know if I run into anymore problems with this as I continue to test my app.

I do have a couple of more questions:

  1. After moving to the 1.14.0 version, I am now having trouble with my RTE content is changed workflow. The cursor in my RTE box seems to be moving itself to the first character of the box each time that the workflow runs (i.e. I pause when typing a continuous string of text). I’ve tested this behavior by reverting to the previous version and in that version the cursor remains at the position in which I stopped typing. Is this a new bug or is there a different workflow that I should be using to save changes?

  2. I don’t understand how the stretch to fit content feature is supposed to work. I was expecting it to behave like a standard multiline input box but the element does not seem to be auto-adjusting in height in any capacity. Is there something I’m missing about this? EDITED TO ADD: I see how this works when you have the element set to “display” Would it be possible to make it auto-adjust in height for default/edit mode as well? I thought about showing/hiding multiple copies of the element based on character count, but that won’t necessarily work when the user has entered bulleted or numbered lists of items…

Thank you


#70

Hello.
We’ll look into these issues. Thanks for understanding.

Regards,
Zeroqode Team.


#71

Next question. When my RTE element is a height of greater than around 140, there is increasing amounts of extra white space between the useable portion of the element and bottom edge of the element’s actual position on my screen. Can you tell me why this is happening? See screen shots for example.

Height 140


Height 400


#72

Hello, Jason,
we have update the plugin with these improvements:

  1. Mentions work perfectly,
  2. Autoresize is working too, (Don’t forget to fill up “Maximum autoresize height” param if “Authoresize” checked ),
  3. ZQ-RTE is filling all the bubble element now,
  4. instead of BB codes you can Use HTML equivalents for example something
  5. Cut off content - not implemented, and cannot be implemented (maybe for “Display only” mode),
  6. Caret position will be remembered by the editor now.
  7. Preselect Font Color

to use these improvements please upgrade the plugin to the latest version, refresh the editor and give it another try
thanks!


#73

With the upgrade to 1.15, my RTE no longer writes to the database. I use the RTE to allow my users to create articles. The RTE is set to create the body of the article when executing the workflow. Version 1.14 works fine.


#74

Thanks for reporting this @jelani_aitch we’ll check it out and update


#75

@jelani_aitch sorry, in the latest version we have changed a bit the way writing to database works (we simplified it).
we have created an “on RTE change” event, which you can use to run a workflow that would create new records/update existing ones etc…
hope this helps
please let me know if you manage to make it work or you need further assistance. thanks!


#76

Thank you for the reply. Can you illustrate what the workflow should look like to write to the database. I’ve tried several workflow variations with no success.

Prior to 1.15, my workflow was to “Create a New Thing” (the article) with the RTE input creating the article body.


#77

it’s best illustrated in our demo https://zeroqode-demo-06.bubbleapps.io/rte
Editor mode: https://bubble.is/page?type=page&name=rte&id=zeroqode-demo-06&tab=tabs-1


#78

Just figured it out. Thanks again!


#79

I am also having trouble with saving to the database with the 1.15 update. I’ve tried to follow the demo you linked to above, but your workflows don’t actually use the “A RTE - Main version content is changed” event. I’m curious as to why you reference this as a new event because I was previously using that event in version 1.14. After I upgrade to 1.15, and when I run my app with the “step-by-step” debugger, it no longer appears that anything is being triggered by changing the content. Thank you.

Also, I don’t see that the autoresize is working either.


#80

@accounting Hi.

Yes, you’re right it seems we didn’t use the “RTE - main version content is changed” event in workflow for writing to database. This was set to be triggered via “saveToDB” custom event in workflow.

As for Autoresize function, please check if the value is set for height while the function is enabled in configuration.

Right now added a new workflow event with use of “RTE - Main Version content is changed” action for writing to DB.

Also the demo was updated with newly added modifications. Please check it here - https://zeroqode-demo-06.bubbleapps.io/rte

Hope this helps and sorry for delay.

Regards,
Zeroqode Team.


#81

Back in version 1.14, when I use the RTE Main Version Content Is Changed workflow in step-by-step debugger mode, a change in the text triggers the action. In versions 1.15 and 1.16, nothing is triggered by typing in the RTE box or otherwise changing the format existing text. Its like it no longer recognizes that the content has been changed. When I revert to 1.14, this particular workflow works as expected and when I upgrade to the current version it doesn’t work. I can’t use your SaveToDB workflow because, once again, I can’t access the element in the context of my repeating group (remember the whole fruits example we worked through last month? Yeah, still me.) I really want to use your plugin in my app. I want to continue to pay for it. But I need it to work correctly. Please. Also, I’m telling you, the autoresize function doesn’t work. Or else I don’t understand what it supposed to be doing. But my RTE box doesn’t behave any differently with or without those two fields checked/number value entered. That’s more of a would be nice but not absolutely necessary for me thing, however.


#82

we have fixed this, please upgrade and refresh the browser to give it a try.
here is a video to demonstrate


thanks