Forum Documentation Showcase Pricing Learn more

ZQ Rich Text Editor - New Plugin From Zeroqode


So have you tried the auto-resize in the context of the repeating group example we worked through above? The RTE box is resizing but its not pushing the content below it further down. I need this to behave like a normal multi-line input box in the context of repeating group. Also, once again, the cursor doesn’t seem to be maintaining itself in the proper position after the “content is changed” workflow has run.


we have just pushed an update and Fixed, stretch to fit content in repeating group.
Also make sure that “Stretch to fit content” is enabled.
please upgrade to the plugin’s latest version, refresh the page and try again


In Version 1.18, the “Stretch to Fit Content” works in my repeating group. However, the problem of the RTE not updating the displayed content when the source of my repeating group is changed has returned. This is the same problem I originally described in Post 65 ZQ Rich Text Editor - New Plugin From Zeroqode on 12/18/18.

I have checked this in two ways:

  1. If I revert to the prior version, the content in my repeating group changes appropriately.
  2. In version 1.18, if I uncheck the “stretch to fit content” box, the content changes appropriately. It does not change when the “stretch to fit content” box is checked.

Please let me know about this issue.

Thank you,


we have pushed an update that fixed updating the displayed content when the source is changed. Added workflow to set focus and show RTE for Lite Mode. ( Focus For Lite Mode )
Please upgrade and confirm if this helped


So the RTE editor seems to be working almost perfectly at this point. The caret position is still not behaving as expected which makes editing text next to impossible. I am using the “When RTE-Mainversion content is changed” event and every time that it runs, the caret moves to after the last character of the editor. Which means that if I’ve typed a string of text and I decide that I want to go back and edit/add to the middle of the string, if I pause for even a second after typing anything new in the middle, I lose the caret position. Considering the nature of editing a block of text includes pausing to gather your thoughts, etc., I’m constantly having to click to manually move the caret to the position I want to be editing. Does this explanation of the problem make sense?


Hi, here is a solution for this:
for the workflow that saves the changes to the database, don’t run an action to set initial content of the editor. Only run it once at the page load, like this

and for saving the changes just run this

in this case the cursor position will not be reset each second

but also, we have added a parameter “Custom amount of seconds until event Content is Changed will trigger”. By default is 1 second. Added this field at the bottom in plugin settings.
if you want to use it please upgrade
I guess there is not much we can do here otherwise.
Hope this helps


The Seconds until event Content is Changed will trigger doesn’t work for me because it appears that if I’ve typed anything in one RTE in my Repeating Group then I click on and start typing in a different RTE in my Repeating Group, after the seconds have passed, the cursor automatically moves itself back to the original RTE, even if I’m in the middle of typing in the new RTE.

In previous versions (I think back in version 1.13.0 and before) the cursor position was not a problem. I don’t understand what is different about the upgrades you’ve made since then that now you can’t make the cursor behave like it did in the previous versions.

I set my initial content directly in the RTE settings.

I cannot set my initial content with Set Initial Content RTE-Mainversion action because my RTE is in a Repeating Group.


can you give us access to your app please? - we found a fix, but want to test it in your app first, is that ok?


we have pushed an update that should fix the issue with the cursor, can you please check?


You’ve fixed the cursor issue, but broke the auto resizing. When my page loads, I get this:

When I start editing the RTE box, it then resizes itself, like this:

Do you still want access to my app? I’m not sure how to make that happen other than changing my application rights to “everyone can view” or “everyone can edit.” I’m currently on a personal plan.


you don’t need to upgrade your plan - - is an agency account so you can easily add it.


ok we have pushed another fix that is supposed to solve the issue you are having, please upgrade and retry.


I’m sorry, but I don’t understand how to make this work. I think I was wrong about the cursor position working in 1.23. It definitely doesn’t work in 1.24. I believe I have added you to my app. I have a page named “Fruit Test” that may be easier for you to work with than my index with the actual data/workflow of my app, but you’re welcome to look at either. Thank you for your help.