Forum Documentation Showcase Pricing Learn more

ZQ Rich Text Editor - New Plugin From Zeroqode

#83

So have you tried the auto-resize in the context of the repeating group example we worked through above? The RTE box is resizing but its not pushing the content below it further down. I need this to behave like a normal multi-line input box in the context of repeating group. Also, once again, the cursor doesn’t seem to be maintaining itself in the proper position after the “content is changed” workflow has run.

0 Likes

#84

Hello,
we have just pushed an update and Fixed, stretch to fit content in repeating group.
Also make sure that “Stretch to fit content” is enabled.
please upgrade to the plugin’s latest version, refresh the page and try again
thanks!

0 Likes

#85

In Version 1.18, the “Stretch to Fit Content” works in my repeating group. However, the problem of the RTE not updating the displayed content when the source of my repeating group is changed has returned. This is the same problem I originally described in Post 65 ZQ Rich Text Editor - New Plugin From Zeroqode on 12/18/18.

I have checked this in two ways:

  1. If I revert to the prior version, the content in my repeating group changes appropriately.
  2. In version 1.18, if I uncheck the “stretch to fit content” box, the content changes appropriately. It does not change when the “stretch to fit content” box is checked.

Please let me know about this issue.

Thank you,

0 Likes

#86

Hello,
we have pushed an update that fixed updating the displayed content when the source is changed. Added workflow to set focus and show RTE for Lite Mode. ( Focus For Lite Mode )
Please upgrade and confirm if this helped
Thanks!

0 Likes

#87

So the RTE editor seems to be working almost perfectly at this point. The caret position is still not behaving as expected which makes editing text next to impossible. I am using the “When RTE-Mainversion content is changed” event and every time that it runs, the caret moves to after the last character of the editor. Which means that if I’ve typed a string of text and I decide that I want to go back and edit/add to the middle of the string, if I pause for even a second after typing anything new in the middle, I lose the caret position. Considering the nature of editing a block of text includes pausing to gather your thoughts, etc., I’m constantly having to click to manually move the caret to the position I want to be editing. Does this explanation of the problem make sense?

0 Likes

#88

Hi, here is a solution for this:
for the workflow that saves the changes to the database, don’t run an action to set initial content of the editor. Only run it once at the page load, like this


and for saving the changes just run this

in this case the cursor position will not be reset each second

but also, we have added a parameter “Custom amount of seconds until event Content is Changed will trigger”. By default is 1 second. Added this field at the bottom in plugin settings.
if you want to use it please upgrade
I guess there is not much we can do here otherwise.
Hope this helps
thanks!

0 Likes

#89

The Seconds until event Content is Changed will trigger doesn’t work for me because it appears that if I’ve typed anything in one RTE in my Repeating Group then I click on and start typing in a different RTE in my Repeating Group, after the seconds have passed, the cursor automatically moves itself back to the original RTE, even if I’m in the middle of typing in the new RTE.

In previous versions (I think back in version 1.13.0 and before) the cursor position was not a problem. I don’t understand what is different about the upgrades you’ve made since then that now you can’t make the cursor behave like it did in the previous versions.

I set my initial content directly in the RTE settings.

I cannot set my initial content with Set Initial Content RTE-Mainversion action because my RTE is in a Repeating Group.

0 Likes

#90

can you give us access to your app please? plugins@zeroqode.com - we found a fix, but want to test it in your app first, is that ok?

0 Likes

#91

we have pushed an update that should fix the issue with the cursor, can you please check?
thanks!

0 Likes

#92

You’ve fixed the cursor issue, but broke the auto resizing. When my page loads, I get this:


When I start editing the RTE box, it then resizes itself, like this:

Do you still want access to my app? I’m not sure how to make that happen other than changing my application rights to “everyone can view” or “everyone can edit.” I’m currently on a personal plan.

0 Likes

#93

you don’t need to upgrade your plan - plugins@zeroqode.com - is an agency account so you can easily add it.
thanks

0 Likes

#94

ok we have pushed another fix that is supposed to solve the issue you are having, please upgrade and retry.
thanks

0 Likes

#95

I’m sorry, but I don’t understand how to make this work. I think I was wrong about the cursor position working in 1.23. It definitely doesn’t work in 1.24. I believe I have added you to my app. I have a page named “Fruit Test” that may be easier for you to work with than my index with the actual data/workflow of my app, but you’re welcome to look at either. Thank you for your help.

0 Likes

#96

hi there,
we have fixed this, please upgrade to the plugin’s latest version.
we have also implemented the following improvements:

Fixed:

  • Inserting an image causes it to overlap other elements.
  • Loading HTML initial content causes overlap.

Added:

  • Enable font sizes checkbox
  • Enable fonts checkbox
  • Images max width (by default is 500)
  • Buttons hover color
  • Border radius
  • Tooltip Border radius

Levon Terteryan

Founder @ Zeroqode

zeroqode-for-web-160x120

Bubble Templates

Bubble Plugins

Bubble Courses

Convert Web to iOS & Android

No-code Development Services

0 Likes

#97

Wow! It seems to be doing everything I need it to now! I will let you know if I discover any more issues.
Thank you for working with me for the past couple of months to get this going. I very much appreciate it.

0 Likes

#98

I’ve noticed that when I load the page that displays my repeating group of RTE’s (content set via the RTE editor, not a workflow action) that the RTE Content Is Changed Event is triggered for each and every RTE in my repeating group. I have the Page Load > Show RG > Scroll To workflow set up but the RTE Content is Changed runs after the Page Load. I tried setting my RTE Content is changed to Only When RTE is focused, but when running in Slow or Step By Step mode, it seems to randomly select certain RTEs to update despite not actively being focused. This means that my page loads with a final scroll position in seemingly random places throughout my RG. This always happens the first time I load the page after opening/logging in, but beyond that it is difficult to reproduce. It sometimes happen when I change the datasource of the RTE, but I can’t figure out a pattern for that. This is a relatively minor annoyance, but it doesn’t look very professional to have the page load scroll position in the middle/end of the page. Do you have any suggestions?

0 Likes

#99

Can you please record a video of the bug to illustrate this, in that video please also show all the settings and workflows - useloom.com - use this tool for the screencast please
thanks

0 Likes

#100

Does this video give you the information you requested?

0 Likes

#101

I was just reading on your forum at zeroqode.com and came across this thread: https://forum.zeroqode.com/t/zq-text-editor-bugs-and-feature-requests-updated-5-march/1502
The issue that I described in my last post seems to be the same thing that Marcus is describing in the “scroll and focus” part of the first message in that thread.

0 Likes

#102

we’ll check this out

0 Likes