Forum Documentation Showcase Pricing Learn more

Bubble Page to PDF - New Plugin from Zeroqode


#41

Hi All

@levon

Yes Im finding it very buggy! I made a quick video on my experiences. Hopefully it will help you ZC out?


#42

Good Morning,

Having watched your video I can tell you how to fix one issue you are having with the cut off. Make sure you also modify the source width and height as well to match the page or element you are trying to print. This will bring everything into one view on the printout.

Hope that helps a little.


#43

we were not able to reproduce this, can you please make a screencast of this error popping up and screenshots of the plugin settings? thanks


#44

we have pushed a new version that should solve the background image issue. Please update the plugin version and then reload the editor. Thanks


#45

Tim, please install the new plugin version and reload the editor - we have fixed the issue (in case you set Auto for Source format)
please let us know if it helped
thanks


#46

As requested. I also unsubscribed and resubscribed to see if that would make a difference. Still the same error.


#47

That fixed it. Thanks, @levon. Now that I’m past that, I’ll keep tweaking it and let you know if anything else comes up.


#48

Thanks @Bradluffy Brad

@levon

Unfortunately I’m still receiving this error.

I only received it when I changed the Target format to “Custom Format”

Also when I do choose a4 from the dropdown and set the source correctly and then hit my button to download the PDF directly into my browser this works but unfortunately it takes over 1 minute to download the report? When before it was so impressively fast… So I’m not quite sure what’s happened there.

I’m really happy to invest some time for you in testing this plugin offline if you need me to? I really feel this is a critical plugin for the bubble community as the solutions out there do not come anywhere close to how good this could be if it function correctly at the speed it was.

Also it’s probably not good for business if people have downloaded buggy plug-ins I mean in the past if I have received a buggy plugin I just delete it and don’t ever go back, I think in the software world its natural to be like that nowadays.

Anyway this is still an amazing plug-in and I cannot wait until it is bug free and working perfectly!


#49

I got that same error any time I tried to use the custom target format field, which I was never able to successfully figure out how to use. (I ended up punting and just using Legal size and hiding a few elements just prior to PDF export, though I’d prefer to get the custom sizing to work.)

Agree on the point about buggy plug-ins. This feels pretty rushed. To an earlier poster’s point, better documentation would also be valuable, especially when one is so used to being able to click the in-context See reference link for all things Bubble. Here we’re kinda left on our own to figure things out. (Though I do appreciate the live forum support, it’d be better to first have it well-documented and working according to that documentation.)


#50

We have pushed an update that should solve the d.map errror


#51

That definitely fixed that. There is only one bug still left that I can see.

Let’s say you have a blog which sits on a page. If you print one page of the blog then change the content and try to print again it does not work anymore. Therefore you can really only make an image of one instance of content on a page before the plugin breaks and doesn’t work anymore.

This is across all browsers. If not fixed it pretty much makes useless the plugin except for static content.

Anybody else having this issue? Where the plugin stops working after changing the content on the same page? Any fixes or workarounds?


#52

Yes, I am experiencing the same error as you also! it only works once.

Also in the original versions it was pretty instant to download… (This was absolutely amazing! ) But now it takes over 1 minute to dump into my browser. @levon is this some thing which can be addressed?

@Bradluffy - are you experiencing the same thing?

This is going to be amazing once it complete.

Great work ZQ!!!


#53

I am still seeing the speed on the first print.

I think this will be one of the best plugins on Bubble once the issues are resolved. I even broke my $5 a month limit for a plugin to get it.


#54

Page takes long time to load. Then how long do I have to do this?


#55

Thanks @Bradluffy That’s interesting!? It’s still take well over a minute for me? I wonder what I’m doing wrong? Or still a bug?


Easiest way to print some HTML?
#56

Any progress on a fix for this? My deployment is basically on hold for this feature.


#57

Hope this does what I need.


#58

Hey Brad, can you give us an access to your app ? bubblestore@bubblewits.com, please also point to the page where we can see this behavior happening. We’d need full editing rights so we could run the app under one of the test users.
We tried multiple times to reproduce the slowness issue but couldn’t do that.
Thanks


#59

So are all the bugs fixed ? :slight_smile:


#60

most of them, except that some users report that plugin is sometimes slow which we couldn’t reproduce on our side. So if you give it a try and let us know that would help :slight_smile: thanks